IPv6

  1. 対応ページ: pp.440-473
  2. 対応試験: CCNPv2.0 Routing and Switching 300-101J ROUTE
  3. カテゴリ: IPv6
  4. サブカテゴリ: なし
  5. IOS: c3725-adventerprisek9-mz.124-15.T14.bin
  6. Cisco ISR 1841, IOS: c1841-adventerprisek9-mz.151-4.M10.bin

グローバルユニキャストアドレス 2000::/3
ユニークローカルユニキャストアドレス FC00::/7 Effectively FD00::/8
リンクローカルユニキャストアドレス FE80::/10

インターフェイスID

EUI-64
64bit Extended Unique Identifier

MACアドレス(EUI-48)

U/L(Universal/Local) ビット

匿名アドレス(一時アドレス) RFC3041
RFC 3041 – Privacy Extensions for Stateless Address Autoconfiguration in IPv6

マルチキャストアドレス

FF00::/8

エニーキャストアドレス

最も近いノードとの通信。

IPv6 ルート集約

IPv6 アドレスの割り当て

手動設定

ステートレスアドレス自動設定(オートコンフィギュレーション)

RFC2462

ネットワークに接続するとルータからプレフィックスが通知される。

近隣探索プロトコル(NDP; Neighbor Discovery Protocol) を使用する。
RS/RA

Router Solicitation

Router Advertisement

主要なプロトコル

ICMPv6

RFC2463
RFC2470
RFC2461

近隣探索プロトコル(NDP)

Neighbor Discovery Protocol

RFC4861

Router Solicitation(RS)
Router Advertisement(RA)

Neighbor Solicitation(NS)
Neighbor Advertisement(NA)

要請ノードマルチキャストアドレスへの参加義務

R1(config)#do sh run | i ipv6
ipv6 unicast-routing
ipv6 cef
R1(config)#ipv6 unicast-routing
R3#sh run | i ipv6
no ipv6 cef
R2(config)#ipv6 unicast-routing
en
conf t
int f0/0
no shut
int f0/1
no shut
end


en
conf t
int f0/0
no shut
end

en
conf t
int f0/0
no shut
end

en
conf t
int f0
no shut
end

en
conf t
int f0
no shut
end

IPv6 の有効化

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv
R1(config)#ipv6 unica
R1(config)#ipv6 unicast-routing
R1(config)#int f0/0
R1(config-if)#ipv
R1(config-if)#ipv6 ena
R1(config-if)#ipv6 enable
R1(config-if)#do sh ipv
% Ambiguous command:  "do sh ipv"
R1(config-if)#do sh ipv6 int
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::21B:2AFF:FE77:66D2
  No Virtual link-local address(es):
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF77:66D2
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.

グローバルユニキャストアドレスの設定

R1(config-if)#ipv6 address 2001:1:1:1::/64 eui-64
R1(config-if)#do sh ipv6 int
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::21B:2AFF:FE77:66D2
  No Virtual link-local address(es):
  Global unicast address(es):
    2001:1:1:1:21B:2AFF:FE77:66D2, subnet is 2001:1:1:1::/64 [EUI]
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF77:66D2
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.

リンクローカルアドレスをわかりやすいアドレスに変更する。

f0/0 において FE80::1 としよう。

R1(config-if)#ipv6 address FE80::1 link-local
R1(config-if)#do sh ipv6 int f0/0
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::1
  No Virtual link-local address(es):
  Global unicast address(es):
    2001:1:1:1::1, subnet is 2001:1:1:1::/64 [EUI]
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF00:1
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.

上記トポロジのように設定してみる。
インターフェイス名はちょっと違うのでご注意。

conf t
int f0/0
ipv6 enable
ipv6 address 2001:1:1:1::/64 eui-64
ipv6 address FE80::1 link-local
int f0/1
ipv6 enable
ipv6 address FE80::1:1 link-local
end

conf t
int f0/0
ipv6 enable
ipv6 address 2001:1:1:1::/64 eui-64
ipv6 address FE80::2 link-local
end

conf t
int f0/0
ipv6 enable
ipv6 address FE80::3 link-local
end

conf t
int f0
ipv6 enable
ipv6 address FE80::1:4 link-local
end

conf t
int f0
ipv6 enable
ipv6 address FE80::1:5 link-local
end

設定が終わったこのとき、 IPv6 ネイバーテーブルを確認すると空っぽ。

R2#sh ipv6 neighbors

ping を打ってみる。

リンクローカルアドレスは出力インターフェイスも指定する必要がある。

出力インターフェイス名は省略形ではなくスペース無しで完全なインターフェイス名を書く必要があるようだ。

R2#ping FE80::1
Output Interface:
% Interface required
R2#ping FE80::1 ?
data specify data pattern
repeat specify repeat count
size specify datagram size
source specify source address or name
timeout specify timeout interval
verbose verbose output

R2#ping FE80::1
Output Interface: f0/0
% Invalid interface. Use full interface name without spaces (e.g. Serial0/1)
Output Interface: FastEthernet0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::1, timeout is 2 seconds:
Packet sent with a source address of FE80::2%FastEthernet0/0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/8 ms

出力の例を見ると % 記述でつなげて出力インターフェイス名を指定できるみたいだ。
YAMAHA でもそんな感じでできた気がする。

R2#ping FE80::1%f0/0
% Unrecognized host or address, or protocol not running.

R2#ping FE80::1%FastEthernet0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::1, timeout is 2 seconds:
Packet sent with a source address of FE80::2%FastEthernet0/0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms

R2#sh ipv6 neighbors
IPv6 Address Age Link-layer Addr State Interface
FE80::1 0 001b.2a77.66d2 REACH Fa0/0

対向の R1 でもネイバーテーブルにキャッシュされる。

R1#sh ipv6 neighbors
IPv6 Address Age Link-layer Addr State Interface
FE80::2 3 0024.c431.126e STALE Fa0/0

グローバルユニキャストアドレス、ならびにユニークローカルユニキャストアドレスは出力インターフェイスを指定する必要はない。

R1#sh ipv6 int f0/0
FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::1
No Virtual link-local address(es):
Global unicast address(es):
2001:1:1:1::1, subnet is 2001:1:1:1::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF00:1
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds (using 30000)
ND advertised reachable time is 0 (unspecified)
ND advertised retransmit interval is 0 (unspecified)
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds
ND advertised default router preference is Medium
Hosts use stateless autoconfig for addresses.

R2#sh ipv6 int
FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::2
No Virtual link-local address(es):
Global unicast address(es):
2001:1:1:1::2, subnet is 2001:1:1:1::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF00:2
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds (using 30000)
ND advertised reachable time is 0 (unspecified)
ND advertised retransmit interval is 0 (unspecified)
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds
ND advertised default router preference is Medium
Hosts use stateless autoconfig for addresses.

R1#ping 2001:1:1:1::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1:1::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/8 ms

こうするとグローバルユニキャストアドレスも IPv6 ネイバーテーブルにのるようになる。

R2#sh ipv6 neighbors
IPv6 Address                              Age Link-layer Addr State Interface
2001:1:1:1::1                               0 001b.2a77.66d2  REACH Fa0/0
FE80::1                                     9 001b.2a77.66d2  DELAY Fa0/0

Windows の GNS3 で Cisco ルーターの設定を初期化する

GNS3 上でトポロジを構成する際、誤ったコンフィグを投入してしまって、あまつさえ保存してしまったとします。
こういった場合設定を初期化したいのですが、 erase startup-config だけだとルーターのホスト名の設定やロギングの挙動の調整といった、
ルーター初回起動時に投入される便利なコンフィグが読み込まれません。
最低限ルーター名だけでも最初から投入してくれないとわかりにくくて大変です。
GNS3 のドキュメント探してみましたが相当するようなドキュメントが見つからなかったので結構苦労しました。

トポロジを構成するルーターが 1, 2 台ならプロジェクト作り直せばいいかで済むんですが、 5 台以上になってくると大変です。
トポロジを作るのに加えてインターフェイスのラベルの位置とか微調整しているので作り直しってなったら発狂したくなります。

つーか、 Mac 版だと コンフィグ消したら NVRAM が勝手に初期化されたから、 Windows 版のバグのような気がしないでもない。

R1#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
R1#
*Mar  1 00:00:26.751: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram

誰か教えて下しあ。。。
GNS3 のドキュメントに載ってるのかな。。
今度腰を据えて GNS3 のドキュメント読もうかな。
というか GNS3 2.0 RC2 までいったようで、熱いね。
もうリリース間近といった感じ。

Releases · GNS3/gns3-gui

以下は Windows 版でのみの話し

ルーター上で

erase startup-config

これでルーターを再起動しても初回起動時に投入されるコンフィグは入らない。
ホスト名も設定されていない完全にまっさらに初期化されたルーターが起動される。
まあ、物理的なルーターの動作としてはこれが正しいんだが、コンセプトを理解したい場合は違う、そうじゃないとなる。

次に、ルーターを停止させる。これ重要。

右クリックでコンフィグをインポートする。

Windows なら

C:\Users\wnoguchi\GNS3\configs\ios_base_startup-config.txt

Mac なら

/Users/wnoguchi/GNS3/configs/ios_base_startup-config.txt

Linux なら(エスパーしている)

/home/GNS3/configs/ios_base_startup-config.txt

ちなみにコンフィグは以下のような感じになっていた。

!
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname %h
!
ip cef
no ip domain-lookup
no ip icmp rate-limit unreachable
ip tcp synwait 5
no cdp log mismatch duplex
!
line con 0
 exec-timeout 0 0
 logging synchronous
 privilege level 15
 no login
line aux 0
 exec-timeout 0 0
 logging synchronous
 privilege level 15
 no login
!
!
end

%h の部分がホスト名に置換されているわけですな。

プライベートコンフィグは読み込まなくて良い。

そしてルーター起動。

これで OK 。

OSPF 認証 インターフェイス認証

  1. 対応ページ: pp.222-225
  2. 対応試験: CCNPv2.0 Routing and Switching 300-101J ROUTE
  3. カテゴリ: OSPF
  4. サブカテゴリ: OSPF 認証 インターフェイス認証
  5. IOS: c3725-adventerprisek9-mz.124-15.T14.bin

OSPF認証について

OSPF認証タイプ

  • タイプ0 Null 認証
  • タイプ1 シンプルパスワード認証
  • タイプ2 MD5 認証

ネイバー認証の設定対象

  • インターフェイス
  • エリア
  • 仮想リンク

トポロジ

GNS3 プロジェクトファイルダウンロード

OSPF 認証設定前までやってあります。

GNS3 1.5.x では Windows, Mac 間の portable project のエクスポート、インポートがうまくいかない | | wnoguchi’s diary

Windows

ospf-authentication-interface

Mac

TODO

基本設定

R1

conf t
int f0/0
ip addr 10.0.12.1 255.255.255.0
no shut
!
! OSPF configuration
router ospf 1
router-id 1.1.1.1
network 10.0.0.0 0.255.255.255 area 0
end
wr

R2(ABR)

conf t
int f0/0
ip addr 10.0.12.2 255.255.255.0
no shut
int s0/0
ip addr 10.1.23.2 255.255.255.0
no shut
!
! OSPF configuration
router ospf 1
router-id 2.2.2.2
network 10.0.0.0 0.0.255.255 area 0
network 10.1.0.0 0.0.255.255 area 1
end
wr

R3

conf t
int s0/0
ip addr 10.1.23.3 255.255.255.0
no shut
!
! OSPF configuration
router ospf 1
router-id 3.3.3.3
network 10.0.0.0 0.255.255.255 area 1
end
wr

VPCs

なし

設定前の動作確認

なし

設定

R1

conf t
int f0/0
ip ospf authentication
ip ospf authentication-key CISCO

R2(ABR)

conf t
int f0/0
ip ospf authentication
ip ospf authentication-key CISCO
int s0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ROUTE

R3

conf t
int s0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ROUTE

検証

インターフェイスで認証が有効になっていることを確認する。

シンプルパスワード認証

R2#sh ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.0.12.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.0.12.2
  Backup Designated router (ID) 1.1.1.1, Interface address 10.0.12.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled

MD5 認証

R2#sh ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.0.12.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.0.12.2
  Backup Designated router (ID) 1.1.1.1, Interface address 10.0.12.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled

ネイバーテーブルを確認して所望のネイバーが認識されていることを確認する。

R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:37    10.0.12.1       FastEthernet0/0
3.3.3.3           0   FULL/  -        00:00:33    10.1.23.3       Serial0/0

おことわり

これは「徹底攻略Cisco CCNP Routing & Switching ROUTE教科書[300-101J]対応 徹底攻略シリーズ」に掲載されているサンプルトポロジのコンフィグを自分で考えて、インターフェイスの対応等微妙に変えて GNS3, あるいは VIRL のプロジェクトファイルとしています。
具体的な説明はここではせず、箇条書き程度の自分用のメモ、コンフィグ、実際の出力結果を載せています。
詳細なコンセプトの説明はこのテキストを参照するか、他のサイトをあたることをおすすめします。

追記

コンフィグやトポロジに誤りがありましたら指摘いただけるとうれしいです!

なんでこんなこと書いているか

Cisco の試験に限らないですけど、私の基本的なスタンスを書いてあります。
随時アップデートしていくので興味あったら覗いてみてください。

Cisco の技術者認定試験における私のスタンス | wnoguchi’s diary

参考書紹介

こちらのテキストを使用させていただいております。
いつもありがとうございます。

個人的なおすすめはテキストは紙版と Kindle 版両方買っておいて、ウォークスルー的なテキストの読み込みは
クロスリファレンスが必要なときは紙の本をざっと開くのがおすすめです。
問題集は紙版さえあればいいかなと思ってますが、もしかすると Kindle 版のほうが効率いいのかも。
どうなんだろ。

GNS3 1.5.x では Windows, Mac 間の portable project のエクスポート、インポートがうまくいかない

ご注意: GNS3 1.5 系のポータブルプロジェクトファイルは私が試した限り Windows と Mac 間では互換性がありません。

それと Windows 間のインポートだとエクスポート元で GNS3 VM 上で実行していたやつでも、インポート先だとローカルの Dynamips で実行されてしまうっぽい。。。
設定の問題なのかなあ。。。

最初この事実を知った時、うーんって感じでした。
まあ、マルチプラットフォームの難しさは推して量るべしですが・・・。
こういったコミュニティに積極的にコミットできるようになりたい。

NSSA(Not So Stubby Area) の実装

  1. 対応ページ: pp.208-221
  2. 対応試験: CCNPv2.0 Routing and Switching 300-101J ROUTE
  3. カテゴリ: OSPF
  4. サブカテゴリ: NSSA
  5. IOS: c3725-adventerprisek9-mz.124-15.T14.bin

NSSAについて

Not So Stubby Area の略。
直訳すれば「それほどにスタブじゃないエリア」。
つまり

  1. ASBR(AS Boundary Router) を配置できるようにスタブエリアを拡張した RFC 準拠のエリアである
  2. ABR はスタブエリアと同様に LSA タイプ4, 5 をブロックする
  3. NSSA 内の ASBR はタイプ 5 の LSA が禁止されているので代わりにタイプ 7 の LSA を使う
  4. ABR はタイプ 7 の LSA をタイプ 5 の LSA に変換する
  5. バックボーンエリア、仮想リンク(Virtual Link)のトランジットエリアを NSSA にすることはできない
  6. NSSA エリアではデフォルトでは ABR はデフォルトルートをアドバタイズしない
    なぜなら ABR の先に外部 AS ネットワークがあるとは限らないから
  7. デフォルトルートのコスト変更

    area <area-id> default-cost <cost>
    

    トポロジ

    GNS3 プロジェクトファイルダウンロード

    NSSA 設定前のものです。
    OSPF, EIGRP, RIPv2 、ルート再配布まわりは設定済みです。

    GNS3 1.5.x では Windows, Mac 間の portable project のエクスポート、インポートがうまくいかない | | wnoguchi’s diary

    Windows

    ospf-nssa-win.gns3project

    Mac

    TODO

    基本設定

    R1(ASBR) EIGRP ドメイン

    conf t
    int s0/1
    ip addr 172.16.0.1 255.255.255.0
    no shut
    int s0/0
    ip addr 10.0.12.1 255.255.255.0
    no shut
    !
    ! OSPF configuration
    router ospf 1
    ! Redistribute EIGRP Route to OSPF
    redistribute eigrp 1 subnets
    router-id 1.1.1.1
    network 10.0.0.0 0.255.255.255 area 0
    !
    ! EIGRP configuration
    router eigrp 1
    ! Redistribute OSPF Route to EIGRP
    redistribute ospf 1
    default-metric 10000 100 255 1 1500
    network 172.16.0.0
    no auto-summary
    end
    wr
    

    R2

    conf t
    int s0/0
    ip addr 10.0.12.2 255.255.255.0
    no shut
    int f0/0
    ip addr 10.0.23.2 255.255.255.0
    no shut
    int f0/1
    ip addr 10.0.2.2 255.255.255.0
    no shut
    !
    ! OSPF configuration
    router ospf 1
    router-id 2.2.2.2
    network 10.0.0.0 0.255.255.255 area 0
    end
    wr
    

    R3(ABR)

    conf t
    int f0/0
    ip addr 10.0.23.3 255.255.255.0
    no shut
    int s0/0
    ip addr 10.1.34.3 255.255.255.0
    no shut
    !
    ! OSPF configuration
    router ospf 1
    router-id 3.3.3.3
    network 10.0.23.0 0.0.0.255 area 0
    network 10.1.34.0 0.0.0.255 area 1
    end
    wr
    

    R4

    conf t
    int s0/0
    ip addr 10.1.34.4 255.255.255.0
    no shut
    int f0/0
    ip addr 10.1.45.4 255.255.255.0
    no shut
    !
    ! OSPF configuration
    router ospf 1
    router-id 4.4.4.4
    network 10.0.0.0 0.255.255.255 area 1
    end
    wr
    

    R5(ASBR) RIPv2 ドメイン

    conf t
    int f0/0
    ip addr 10.1.45.5 255.255.255.0
    no shut
    int f0/1
    ip addr 10.1.5.5 255.255.255.0
    no shut
    int s0/1
    ip address 192.168.1.5 255.255.255.0
    no shut
    !
    ! OSPF configuration
    router ospf 1
    router-id 5.5.5.5
    ! Redistribute RIPv2 Route to OSPF
    redistribute rip subnets
    network 10.0.0.0 0.255.255.255 area 1
    !
    ! RIPv2 configuration
    router rip
    version 2
    ! Redistribute OSPF Route to RIP
    redistribute ospf 1 metric 5
    network 192.168.1.0
    no auto-summary
    end
    wr
    

    R6 EIGRP AS1 ドメイン

    conf t
    int s0/0
    ip address 172.16.0.6 255.255.255.0
    no shut
    int f0/0
    ip address 172.16.1.6 255.255.255.0
    no shut
    int f0/1
    ip address 172.16.2.6 255.255.255.0
    no shut
    int f1/0
    ip address 172.16.3.6 255.255.255.0
    no shut
    !
    ! EIGRP configuration
    router eigrp 1
    network 172.16.0.0
    no auto-summary
    end
    wr
    

    R7 RIPv2 ドメイン

    conf t
    int s0/0
    ip addr 192.168.1.7 255.255.255.0
    no shut
    int f0/0
    ip addr 192.168.2.7 255.255.255.0
    no shut
    int f0/1
    ip addr 192.168.3.7 255.255.255.0
    no shut
    !
    ! RIPv2 configuration
    router rip
    version 2
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    no auto-summary
    end
    wr
    

    VPCs

    PC1

    ip 10.0.2.21 255.255.255.0 10.0.2.2
    save
    

    PC2

    ip 10.1.5.52 255.255.255.0 10.1.5.5
    save
    

    PC3

    ip 172.16.1.63 255.255.255.0 172.16.1.6
    save
    

    PC4

    ip 172.16.2.64 255.255.255.0 172.16.2.6
    save
    

    PC5

    ip 172.16.3.65 255.255.255.0 172.16.3.6
    save
    

    PC6

    ip 192.168.2.76 255.255.255.0 192.168.2.7
    save
    

    PC7

    ip 192.168.3.77 255.255.255.0 192.168.3.7
    save
    

    設定前の動作確認

    NSSA 設定前の動作を確認する。
    スタブエリア設定前のルーティングテーブルは以下のようになる。

    R4#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         172.16.0.0/24 is subnetted, 4 subnets
    O E2    172.16.0.0 [110/20] via 10.1.34.3, 01:52:21, Serial0/0
    O E2    172.16.1.0 [110/20] via 10.1.34.3, 01:52:20, Serial0/0
    O E2    172.16.2.0 [110/20] via 10.1.34.3, 01:52:20, Serial0/0
    O E2    172.16.3.0 [110/20] via 10.1.34.3, 01:52:19, Serial0/0
         10.0.0.0/24 is subnetted, 6 subnets
    O IA    10.0.12.0 [110/138] via 10.1.34.3, 01:52:26, Serial0/0
    O IA    10.0.2.0 [110/84] via 10.1.34.3, 01:52:26, Serial0/0
    O       10.1.5.0 [110/20] via 10.1.45.5, 01:50:28, FastEthernet0/0
    O IA    10.0.23.0 [110/74] via 10.1.34.3, 01:52:47, Serial0/0
    C       10.1.45.0 is directly connected, FastEthernet0/0
    C       10.1.34.0 is directly connected, Serial0/0
    O E2 192.168.1.0/24 [110/20] via 10.1.45.5, 01:50:28, FastEthernet0/0
    O E2 192.168.2.0/24 [110/20] via 10.1.45.5, 01:50:07, FastEthernet0/0
    O E2 192.168.3.0/24 [110/20] via 10.1.45.5, 01:50:07, FastEthernet0/0
    

    設定

    R3(ABR)

    conf t
    router ospf 1
    area 1 nssa default-information-originate
    end
    

    テキストには area 1 nssa default-information originate と書いてあるけどどのバージョンの IOS のコマンドなんだろ。。。
    つーか、テキストのいっちゃん最初に IOS 15 に基づいてなんちゃらって書いてあるな。。。

    こういうとき役立つのが IOS 15 の載っている実機や VIRL 。

    と思って Cisco 1841 (c1841-adventerprisek9-mz.151-4.M10.bin) の実機で確認したけど default-information-originate だったぞ。。

    R4(内部ルータ)

    conf t
    router ospf 1
    area 1 nssa
    end
    

    R5(ASBR)

    conf t
    router ospf 1
    area 1 nssa
    end
    

    検証

    NSSA 設定後の内部ルータ R4 の LSDB

    R4#sh ip ospf database
    
                OSPF Router with ID (4.4.4.4) (Process ID 1)
    
                    Router Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    3.3.3.3         3.3.3.3         130         0x80000003 0x00947F 2
    4.4.4.4         4.4.4.4         119         0x80000006 0x00AFCC 3
    5.5.5.5         5.5.5.5         120         0x80000005 0x00A1AF 2
    
                    Net Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.1.45.5       5.5.5.5         120         0x80000003 0x006C50
    
                    Summary Net Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.0.2.0        3.3.3.3         156         0x80000002 0x000307
    10.0.12.0       3.3.3.3         156         0x80000002 0x00B217
    10.0.23.0       3.3.3.3         156         0x80000003 0x00B449
    
                    Type-7 AS External Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    0.0.0.0         3.3.3.3         156         0x80000001 0x00B2F2 0
    192.168.1.0     5.5.5.5         126         0x80000001 0x000201 0
    192.168.2.0     5.5.5.5         126         0x80000001 0x00F60B 0
    192.168.3.0     5.5.5.5         126         0x80000001 0x00EB15 0
    

    LSA タイプ 7 の詳細情報

    R4#show ip ospf database nssa-external
    
                OSPF Router with ID (4.4.4.4) (Process ID 1)
    
                    Type-7 AS External Link States (Area 1)
    
      Routing Bit Set on this LSA
      LS age: 1720
      Options: (No TOS-capability, No Type 7/5 translation, DC)
      LS Type: AS External Link
      Link State ID: 0.0.0.0 (External Network Number )
      Advertising Router: 3.3.3.3
      LS Seq Number: 80000003
      Checksum: 0xAEF4
      Length: 36
      Network Mask: /0
            Metric Type: 2 (Larger than any link state path)
            TOS: 0
            Metric: 1
            Forward Address: 0.0.0.0
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 1689
      Options: (No TOS-capability, Type 7/5 translation, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.0 (External Network Number )
      Advertising Router: 5.5.5.5
      LS Seq Number: 80000003
      Checksum: 0xFD03
      Length: 36
      Network Mask: /24
            Metric Type: 2 (Larger than any link state path)
            TOS: 0
            Metric: 20
            Forward Address: 10.1.5.5
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 1690
      Options: (No TOS-capability, Type 7/5 translation, DC)
      LS Type: AS External Link
      Link State ID: 192.168.2.0 (External Network Number )
      Advertising Router: 5.5.5.5
      LS Seq Number: 80000003
      Checksum: 0xF20D
      Length: 36
      Network Mask: /24
            Metric Type: 2 (Larger than any link state path)
            TOS: 0
            Metric: 20
            Forward Address: 10.1.5.5
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 1691
      Options: (No TOS-capability, Type 7/5 translation, DC)
      LS Type: AS External Link
      Link State ID: 192.168.3.0 (External Network Number )
      Advertising Router: 5.5.5.5
      LS Seq Number: 80000003
      Checksum: 0xE717
      Length: 36
      Network Mask: /24
            Metric Type: 2 (Larger than any link state path)
            TOS: 0
            Metric: 20
            Forward Address: 10.1.5.5
            External Route Tag: 0
    

    NSSA 設定後の内部ルータ R4 の ルーティングテーブル

    R4#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 10.1.34.3 to network 0.0.0.0
    
         10.0.0.0/24 is subnetted, 6 subnets
    O IA    10.0.12.0 [110/138] via 10.1.34.3, 00:02:19, Serial0/0
    O IA    10.0.2.0 [110/84] via 10.1.34.3, 00:02:19, Serial0/0
    O       10.1.5.0 [110/20] via 10.1.45.5, 00:02:09, FastEthernet0/0
    O IA    10.0.23.0 [110/74] via 10.1.34.3, 00:02:19, Serial0/0
    C       10.1.45.0 is directly connected, FastEthernet0/0
    C       10.1.34.0 is directly connected, Serial0/0
    O N2 192.168.1.0/24 [110/20] via 10.1.45.5, 00:02:09, FastEthernet0/0
    O N2 192.168.2.0/24 [110/20] via 10.1.45.5, 00:02:11, FastEthernet0/0
    O N2 192.168.3.0/24 [110/20] via 10.1.45.5, 00:02:11, FastEthernet0/0
    O*N2 0.0.0.0/0 [110/1] via 10.1.34.3, 00:02:21, Serial0/0
    

    上記から分かるとおり、R3(ABR) はタイプ 5 LSA でアドバタイズされる EIGRP ドメインのルート情報をブロックしている。
    そのかわり default-information-originate でデフォルトルートを LSA タイプ 7 でアドバタイズしている。

    また R2 は R3 から RIP のルート情報を LSA タイプ 5 に変換されたものを受け取っている。

    R2#sh ip ospf database external 192.168.1.0
    
                OSPF Router with ID (2.2.2.2) (Process ID 1)
    
                    Type-5 AS External Link States
    
      Routing Bit Set on this LSA
      LS age: 278
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.0 (External Network Number )
      Advertising Router: 3.3.3.3
      LS Seq Number: 80000001
      Checksum: 0xD242
      Length: 36
      Network Mask: /24
            Metric Type: 2 (Larger than any link state path)
            TOS: 0
            Metric: 20
            Forward Address: 10.1.5.5
            External Route Tag: 0
    

    R2 (バックボーンエリアの内部ルータ)のルーティングテーブル

    R2#sh ip ro
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         172.16.0.0/24 is subnetted, 4 subnets
    O E2    172.16.0.0 [110/20] via 10.0.12.1, 00:12:42, Serial0/0
    O E2    172.16.1.0 [110/20] via 10.0.12.1, 00:12:42, Serial0/0
    O E2    172.16.2.0 [110/20] via 10.0.12.1, 00:12:42, Serial0/0
    O E2    172.16.3.0 [110/20] via 10.0.12.1, 00:12:42, Serial0/0
         10.0.0.0/24 is subnetted, 6 subnets
    C       10.0.12.0 is directly connected, Serial0/0
    C       10.0.2.0 is directly connected, FastEthernet0/1
    O IA    10.1.5.0 [110/94] via 10.0.23.3, 00:06:28, FastEthernet0/0
    C       10.0.23.0 is directly connected, FastEthernet0/0
    O IA    10.1.45.0 [110/84] via 10.0.23.3, 00:06:39, FastEthernet0/0
    O IA    10.1.34.0 [110/74] via 10.0.23.3, 00:11:59, FastEthernet0/0
    O E2 192.168.1.0/24 [110/20] via 10.0.23.3, 00:06:23, FastEthernet0/0
    O E2 192.168.2.0/24 [110/20] via 10.0.23.3, 00:06:24, FastEthernet0/0
    O E2 192.168.3.0/24 [110/20] via 10.0.23.3, 00:06:24, FastEthernet0/0
    

    トターリーNSSA

    Cisco 独自の拡張。
    LSA タイプ 3 もブロックする。
    すなわちデフォルトルートによって基本的に外部エリア、AS との通信はおこなう。
    タイプ 1, 2 および 7 のみ。

    (config-router)#area <area-id> nssa no-summary
    

    デフォルトルートを生成することが前提のため、 default-information-originate は不要である。

    R3(ABR)

    router ospf 1
    area 1 nssa no-summary
    

    R4 の LSDB

    R4#sh ip ospf database
    
                OSPF Router with ID (4.4.4.4) (Process ID 1)
    
                    Router Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    3.3.3.3         3.3.3.3         1580        0x80000003 0x00947F 2
    4.4.4.4         4.4.4.4         1572        0x80000006 0x00AFCC 3
    5.5.5.5         5.5.5.5         1572        0x80000005 0x00A1AF 2
    
                    Net Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.1.45.5       5.5.5.5         1572        0x80000003 0x006C50
    
                    Summary Net Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum
    0.0.0.0         3.3.3.3         727         0x80000001 0x00DE4B
    
                    Type-7 AS External Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    0.0.0.0         3.3.3.3         1589        0x80000001 0x00B2F2 0
    192.168.1.0     5.5.5.5         1578        0x80000001 0x000201 0
    192.168.2.0     5.5.5.5         1578        0x80000001 0x00F60B 0
    192.168.3.0     5.5.5.5         1578        0x80000001 0x00EB15 0
    

    R4 のタイプ 3 LSA の詳細表示

    R4#sh ip ospf da sum
    
                OSPF Router with ID (4.4.4.4) (Process ID 1)
    
                    Summary Net Link States (Area 1)
    
      Routing Bit Set on this LSA
      LS age: 902
      Options: (No TOS-capability, DC, Upward)
      LS Type: Summary Links(Network)
      Link State ID: 0.0.0.0 (summary Network Number)
      Advertising Router: 3.3.3.3
      LS Seq Number: 80000001
      Checksum: 0xDE4B
      Length: 28
      Network Mask: /0
            TOS: 0  Metric: 1
    

    R4 のルーティングテーブル

    R4#sh ip ro
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 10.1.34.3 to network 0.0.0.0
    
         10.0.0.0/24 is subnetted, 3 subnets
    O       10.1.5.0 [110/20] via 10.1.45.5, 00:14:50, FastEthernet0/0
    C       10.1.45.0 is directly connected, FastEthernet0/0
    C       10.1.34.0 is directly connected, Serial0/0
    O N2 192.168.1.0/24 [110/20] via 10.1.45.5, 00:14:50, FastEthernet0/0
    O N2 192.168.2.0/24 [110/20] via 10.1.45.5, 00:14:50, FastEthernet0/0
    O N2 192.168.3.0/24 [110/20] via 10.1.45.5, 00:14:50, FastEthernet0/0
    O*IA 0.0.0.0/0 [110/65] via 10.1.34.3, 00:00:48, Serial0/0
    

    EIGRP ルートが消えてスッキリしましたね。

    おことわり

    これは「徹底攻略Cisco CCNP Routing & Switching ROUTE教科書[300-101J]対応 徹底攻略シリーズ」に掲載されているサンプルトポロジのコンフィグを自分で考えて、インターフェイスの対応等微妙に変えて GNS3, あるいは VIRL のプロジェクトファイルとしています。
    具体的な説明はここではせず、箇条書き程度の自分用のメモ、コンフィグ、実際の出力結果を載せています。
    詳細なコンセプトの説明はこのテキストを参照するか、他のサイトをあたることをおすすめします。

    追記

    コンフィグやトポロジに誤りがありましたら指摘いただけるとうれしいです!

    なんでこんなこと書いているか

    Cisco の試験に限らないですけど、私の基本的なスタンスを書いてあります。
    随時アップデートしていくので興味あったら覗いてみてください。

    Cisco の技術者認定試験における私のスタンス | wnoguchi’s diary

    参考書紹介

    こちらのテキストを使用させていただいております。
    いつもありがとうございます。

    個人的なおすすめはテキストは紙版と Kindle 版両方買っておいて、ウォークスルー的なテキストの読み込みは
    クロスリファレンスが必要なときは紙の本をざっと開くのがおすすめです。
    問題集は紙版さえあればいいかなと思ってますが、もしかすると Kindle 版のほうが効率いいのかも。
    どうなんだろ。

Cisco の技術者認定試験における私のスタンス

導入

ちょっと主語が大きすぎるだろうか?
最近やっと CCNAv3.0 R&S (Routing and Switching) のトラックを取得することができました。
今は CCNPv2.0 の ROUTE 試験のトラックの学習をしています。

なので CCNAv3.0 R&S レベルの時点での私のネットワークの技術習得に関する考えを書いています。
他のブログ記事でコンフィグとトポロジー、GNS プロジェクトファイルを載せている理由も書いています。
すでに CCNP, CCIE 持ってるしマルチベンダでバリバリやってるぜって人は時間を無駄にしたくない人はそっ閉じしてください。
マサカリ投げたい人ははてブやコメント欄でどうぞ。
あくまで一個人の意見です。

お前誰だよ?

現場ではインフラ側で YAMAHA ルーター等を中心に中小ブランチネットワークや拠点間の VPN 設計・実装等をやっています。
どちらかというとサーバー要素多めで、最近はオンプレで食っていくには小手先のネットワーク知識じゃだめだなと思って Cisco の技術者認定資格の取得に力を入れています。

ネットワークの技術の学習方法

私は実機、シミュレータで実際に動かしてみないとその技術のコンセプトが理解できないたちなので、
テキストや問題集に載っているやつは実際にトポロジを組んでシミュレーターで動かしてコマンド打ち込んでルーターの動きがどう変わるかちゃんと見て理解した上で進めています。

実機をいつ使うか?

実機使うのは本当に基礎的なトピックを理解するために使います。

  1. 物理層(L1)、データリンク層(L2)の細かい動きを確認して実機の動きとシミュレーター上での動きはどう違うのか理解する。
    1. Cisco VIRL で IOSvL2 で STP 実験してみようと思ったらリンク状態が全二重じゃなくて半二重になってて全然意味わからなかったときとかあります。
    2. MDI 同士、MDI-X 同士をつなぐときはクロスケーブル使わないと物理層レベルでだけ up してデータリンク層レベルでは down するよとか。
    3. 今まで Auto MDI/MDI-X に頼ってばかりいましたけど、Cisco ルーター同士をストレート(今市場に大量に出回っているのがこればっかし)直結すると no shut してもリンクアップしなくて困ったりとか。
  2. ロールオーバー(シリアルコンソール)ケーブルをつなぐときはクロスケーブル(だいたいこっちでいい)、ストレートケーブル間違えると正常につなげらんないよとか。
  3. 新しいコンセプトの Hello World 的な構成を試す時とか(RIP, EIGRP, OSPF)。
  4. STP の三角形とか、自分自身につないでループする構成とか(下記)。

ループ接続のイラスト | かわいいフリー素材集 いらすとや

シミュレーターの使い所

シミュレーターを使うのは基本的なこと理解したらようし複数台構成してもっと深いコンセプトを理解するぞってときにやります。
正直 CCNP レベルになってくるとルーターの数 5 台のトポロジとか解説に平気で出てくるので毎回実機使ってたらやってらんないので GNS3 や Cisco VIRL を使っています。。。。
初めてのコンセプトの実装・検証は上記のとおり実機でやります。

実務的な面

いくらシミュレーターで検証しようが、 Visio トポロジーをきれいに書こうが実際にデプロイされるのは物理的な環境です。
いざネットワーク機器の実機や VyOS の VM を目の前にして慌てるようでは目も当てられません。

Cisco 試験の方法論

本読んでひたすら問題集解いて試験 Pass できる人はいいなあと思います。
コンセプト理解しただけで他のベンダのネットワーク機器のマニュアル読んでふんふん設計・設定できるほど私は頭良くないので。。。

まあ、コンセプト理解するだけじゃなくて試験対策として問題集、や ping-t やりまくるのは必要ですけど。
最近は円安が進んで試験の値段がどんどん値上がりしています。
一回落ちると 4 万近くが吹っ飛んでいきます。
順当に CCNP ROUTE, SWITCH, TSHOOT に Pass したとしても 12 万近く吹っ飛ぶわけです。
軽い気持ちで受けられないわけです。
まあ、試験自体は東京の Pearson VUE に登録してお気に入りの試験センター見つけた休みの日にらふらっと行って当日受験なんてことも普通にできますけど。

まとめ

ということでテキストを読むだけでなく、コンセプトをちゃんと(私が)理解するためにテキストには書かれないコンフィグをちゃんと載せて、 GNS3 のプロジェクトファイルも載せているわけです。

CCNP v2.0 について思うこと

CCNA も 2 年経たずに v3.0 に改定された。
なんだか CCNP v2.0 の教科書の出力も IOS 12 系っぽい。
なんかもうそろそれええやろって感じで v3.0 にしまーすって流れになりそうな気がプンプンしてる。

using putty alternative Tera Term

最近 Tera Term の代わりに putty を使うようにした。
あんまり何がそんなに便利なのかよくわかってないんだけど、世界的に見ると putty 使いが圧倒的なシェアを誇っているみたいなので、 putty を積極的に使っていきたい。